寻求一个能够记录/恢复Windows文件资源管理器的浏览状态的工具

如题。我工作的时候需要打开大量的文件夹,以便随时从中调阅文件、执行操作。显然,如果这些文件夹全部都被关掉的话,要重新打开会是一件非常麻烦的事。平时依靠系统休眠和“启动后恢复之前打开的文件夹”设置,尚可以快速便利地恢复工作状态,然而偶尔遇上蓝屏、或者启动故障之类的问题,就会丢掉这些打开的文件夹,需要之后手动恢复,无疑是十分之烦扰了。

因此,寻求一个能记录和恢复文件资源管理器的浏览状态的软件或者插件,基本上可以视作Chrome/Edge上的SessionBuddy的文件浏览器版本。需要其能够在后台静默记录当前处于打开状态的文件夹,不需要额外的操作,同时占用的资源尽可能地少。

先行致谢~~

如果只是针对文件夹的话.

首先开启系统自带的功能: 登录时还原上次打开的窗口.

QTTaber , 是资源管理器的多标签插件, 支持标签历史记录. 可以撤销关闭的标签. 支持群组模式一次性打开多个文件夹. 支持收藏夹.

Directory Opus , 多标签增强型文件夹管理器, 支持关闭时保存上次打开的标签. 支持QTTaber的上述功能.

1 Like

你也可以用ahk 写一个.

大概思路就是间隔时间内, 记录所有打开的文件夹路径. 下次开机时, 一键还原.

1 Like

我还找到一个 CYY超级启动

它可以 自动记录上次关机时桌面上任何软件、文件夹、网页的状态,以便在下次重启电脑时选择使用。

不过这个软件很老了. win10下能否正常运作不好说.

1 Like

感谢回复。

文件夹选项里的那个设置我已经打开了,所以正如主楼中所述,日常使用没什么问题。

Directory Opus略贵了点,之前就一直在犹豫要不要买。QTTaber看起来似乎很不错,我准备试用一下。正好我对资源管理器的多标签页化也非常有兴趣。非常感谢你的推荐。

image

在单位,没有狗,无法编译,所以就把源码发给你,感兴趣的话自己编译(盗版随处可见)一下。
每5秒自动保存当前打开的资源管理器窗口,当然也可以手动保存。然后可以一键reload…

哦,前提是把资源管理器中的那个路径显示在标题选项打开。

.版本 2
.支持库 spec
.支持库 shell

.程序集 窗口程序集_启动窗口

.子程序 _时钟1_周期事件
.局部变量 窗口组, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 路径, 文本型

删除文件 (取运行目录 () + “\config.ini”)
窗口_模糊遍历窗口 (, “CabinetWClass”, , 窗口组)
调试输出 (“窗口组”, 窗口组)
.计次循环首 (取数组成员数 (窗口组), i)
    路径 = 窗口_取标题 (窗口组 [i])
    写配置项 (取运行目录 () + “\config.ini”, “窗口组”, “窗口” + 到文本 (窗口组 [i]), 路径)
.计次循环尾 ()


.子程序 _按钮2_被单击

时钟1.时钟周期 = 5000


.子程序 _按钮1_被单击
.局部变量 窗口组, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 路径, 文本型

时钟1.时钟周期 = 0
删除文件 (取运行目录 () + “\config.ini”)
窗口_模糊遍历窗口 (, “CabinetWClass”, , 窗口组)
调试输出 (“窗口组”, 窗口组)
.计次循环首 (取数组成员数 (窗口组), i)
    路径 = 窗口_取标题 (窗口组 [i])
    写配置项 (取运行目录 () + “\config.ini”, “窗口组”, “窗口” + 到文本 (窗口组 [i]), 路径)
.计次循环尾 ()


.子程序 _按钮3_被单击
.局部变量 配置项数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 路径, 文本型

文件_取配置项名数组 (取运行目录 () + “\config.ini”, “窗口组”, 配置项数组)
调试输出 (配置项数组)
.计次循环首 (取数组成员数 (配置项数组), i)
    路径 = 读配置项 (取运行目录 () + “\config.ini”, “窗口组”, 配置项数组 [i], )
    执行 (4, 路径, , , )
.计次循环尾 ()

或者等我晚上回家编译成可执行文件再发给你也可以。

1 Like

我用qdir,能够把打开的文件夹全都保存为一个.qdr文件,比如我就有FFmpeg、图片、视频分类,
点击一下就瞬间切换到相关的各种文件夹打开状态

1 Like

非常非常地感谢。不过因为我目前正在试用QTTaber,而且因为以前没接触过易语言、想要搞定编译怕不是要从开发环境开始全折腾一遍,所以这个方案就只好暂时当作后备了,抱歉啊。

QTTabber用着感觉不错,而且还同时带来了我一直有兴趣的多标签页资源管理器,挺赞的。

嗯嗯,没关系的,主要还是一个交流和学习,具体用什么方案解决倒不是重点了。
另外说一句,您可能是被python之类的编程语言误导了,以为所有编程语言的使用都很麻烦,从下载到安装到配置环境到编译一大堆麻烦事。在易语言这里不是的,所有过程就是安装好,然后就可以编译了,编译过程也不需要任何参数配置之类的,鼠标点一下就一键编译好了,一点都不麻烦

1 Like

易语言经常被误杀这个事挺麻烦的. :rofl:

火绒这方面做的挺好,对易语言这款国产编程软件也非常支持。
其官方曾经有个帖子,批评了部分外国查毒软件的弱智和以360为代表的一批国产买办阶级杀毒软件的无耻!表示火绒不搞株连,实事求是,该报就报,看不懂或者分析难度大的也不会一律以报毒来显示自己查杀率高。
DTE历史上曾经被火绒报过一次,我反映到火绒官方后,当天就确认是误报,升级病毒库解决了。赞!
我把那篇帖子推荐给易语言官方,被吴涛给置顶了,现在还在易语言官方网站上挂着呢。

火绒的确不错. 不过火绒的查杀能力偏低也是事实.

这事吧,也不想说的太多,在某些地方因为这种事情两帮人能直接干起来。
就我五年以上的使用经验来看,火绒的杀毒能力可能偏弱,但够用。就好像你在家放个小匕首作为家庭防卫装备,防卫能力肯定不如一把40米大砍刀,但真的够用了。
因为只要规范良好的上网,自己不去做死专门找什么千年一遇的全世界罕见病毒包进行测试,火绒够用。
尤其是稍微研究和利用一下它的主动防御规则,那真的就没啥可担心的了。

不至于. 毕竟我卸载360用火绒很多年了. 我用火绒2.0就开始用起了.

我只是试图客观评价它们的差异而已.

火绒的理念,我总结是“够用就好”。它不去追求大而全的病毒库,去包括前后五千年,左右五大洲的所有人类曾经见过的病毒,仅仅是针对它自己判断的当前在国内对用户威胁较大的病毒和木马(当然这么说好像让人以为它对其他病毒就毫无防护能力了,其实不是这样的)。
所以用常见的病毒包的检测方法来比较火绒和360之类的,火绒的查杀结果就显得很寒酸了。更不用说360之类的超高的误报率(所以对这方面比较了解的专业人士都对360评价不高,只有小白才喜欢360这种一惊一乍的表现)。

首先我声明一下, 我非常不喜欢360啊.

火绒不是够用就好, 这不是它的理念. 它的理念是不打扰.

安全防护这个事情, 没有哪个公司敢说够用就好的.

病毒库这个事情, 以前是特征码, 所以越大越好. 现在特征码很难对付病毒的变异, 也就是说特征码更适合早期病毒.

当然了, 并不是说现在特征码就没用了, 而是作用和地位降低了.

而且特征码需要发现后上报, 收集整理出特征码之后再更新到每个用户.

这就对杀软公司要求非常高效,高能力,而且用户数量必须广, 且要支持可疑自动上传才能实现对已知新病毒的快速反馈才行.

这一点, 火绒是个小公司, 对比360不是一个量级.

360现在是国家队, 黑客界的大佬很多. 单论员工水平都不是一个量级.

除去特征码, 行为防控国内最早有名的是微点.

就是著名的瑞星勾结诬陷微点案.

在行为防控上, 360和火绒也不是一个量级. 火绒是基于规则防控, 更简单一些, 但资源占用也更少.

所以够用就好是你的理念, 而不是火绒的. :stuck_out_tongue_winking_eye:

我用火绒一方面是个人良好的习惯, 另一方面是我会用火绒剑手工查杀.

事实上, 我开发的公文助手, 经常被360误报. 火绒从未误报. 微软wd误报过一次.

为啥呢, 因为我的安装包提供了自动下载.net框架的能力. 对于360来说, 你这就是木马下载器啊. 它才不管你是不是访问的微软官网.

是滴,我说啦,“够用就好”是我自己总结滴。哈哈

你们太能聊了,聊一会就跑偏了 :joy: