第一次测试本地恢复论坛数据|居然是磁盘不够用。

论坛一直有自动备份功能,路径大概是服务器本地备份,然后每日自动传输到 Koofr,就结束了。

本地保存两份,Koofr 保存一个月。

但是,这个路径从来没有完成的跑过一次,比如…恢复。

今天在本地的 wsl 中,尝试恢复了一次。

先通过 rclone 从 Koofr 获取数据,第一次知道了 rclone gui 的存在,还挺方便的

开始提示需要130个小时传输 6GB 数据,我就去睡觉了。一晚上回来下好了。

然后就是恢复:

看起来快好了,但实际上因为磁盘不够,已经折腾过一次了,把 wsl 从 C 盘移动到了 D 盘 :sob:

但我没料到,恢复的时候,需要非常多的磁盘空间,原本剩余 40GB 的 C 盘居然不够。

主要位于 ~/discourse/tmp 目录,有30GB大小,主要内容就是恢复文件:

discourse-2026-10-01-193739-v20260923141924.tar.gz dump.sql dump.sql.gz uploads

而期间又需要升级本地开发环境。

110G的磁盘,居然不够恢复的,我现在的问题是,如果有一天需要恢复,那么至少要150G的磁盘,才够用啊。

现在,我也不知道该干嘛了,因为它还没结束

我一直好奇为啥数据库的备份恢复为啥不能是增量式的而是每次都要全部数据搞一遍。。。

我也不知道呀。

我大概知道了,他是一套完整的备份和恢复机制,但是因为使用 PostgreSQL,所以你可以自己来增量备份。

现成的增量很完善

失败了 :sob:

还没成功…

这次把问题排除的差不多了,但是!

只能移动走,再试一次了 :sob:

泪,终于成功了。

3 个赞

可喜可贺 :clap: