为什么论坛要强制浏览器版本啊?

我用的Firefox84,直接浏览论坛会提示版本,显示不全
改ua为chrome就可以了
明明本身就支持,非要多装个浏览器扩展

说实话有点烦

這個大概是論壇軟件自帶的限制,兼容老版本瀏覧器需要成本。

不是“强制浏览器版本”,而是开发时不可能兼容所有版本,只能尽可能地兼容比较新的版本。

所以要划一条线,确定需要兼容哪些版本,才能方便开发,不然开发都不知道哪些语法可以书写、哪些功能可以使用。

在这条线之下的浏览器怎么办呢?就需要提示用户:你的浏览器我不支持,快点更新吧!

但低于这条线又不是所有功能都不能使用,所以你可以通过忽略警告、改 UA 等方式绕过它,只是这样就不能保证你的使用体验了。

1 Like

不过 84 是2020的产品….也淘汰的太早了点

火狐 < 89 在向光标处插入文字时有 bug

我试了下各种方法,通过插件修改 UA 是最简单的一种 :joy:

106b9表示没任何问题

都用火狐了,为什么不更新到最新?

因为新ui我接受不了啊

ui可以改啊

我本身84就改了ui的,最新的Firefox我也用过,用了很多方法都改不到以前的那样,所以只能降级

以后被淘汰了我就只能投奔微软了,Firefox越来越劝退